你好,欢迎来到织梦之家,你可以免费观看大量视频教程以及大量模板下载!

PHP高版本让DedeCMS完美织梦CMS兼容PHP5.4 办理织梦靠山登岸空缺问题-织梦之家(dedehome.com)

时间:2017-09-14 06:02 来源:织梦之家作者:织梦之家 点击:
最近处事器举办的了系统进级,同时也进级的了PHP版本,发下之前的GBK版本的dedecms织梦文件打点系统靠山登岸呈现了问题。 可能各人在用dede的时候会发明,措施装

最近处事器举办的了系统进级,同时也进级的了PHP版本,发下之前的GBK版本的dedecms织梦文件打点系统靠山登岸呈现了问题。

第一

在靠山登岸之后,系统设置内里会空缺,在dede/templet/sys_info.htm文件 将

htmlspecialchars($str, ENT_COMPAT ,'GB2312');

htmlspecialchars这个函数 php高版本有点不兼容了、

第二

可能各人在用dede的时候会发明,措施装好后,登录靠山却发明是一片空缺的。但换其他呆板又没问题。那是织梦默认的是不支持php5.4版本的。
无法正常登录,将下面代码粘贴到/include/helpers/util.helper.php中:
 

// Fix for removed Session functions function fix_session_register(){ function session_register(){ $args = func_get_args(); foreach ($args as $key){ $_SESSION[$key]=$GLOBALS[$key]; } } function session_is_registered($key){ return isset($_SESSION[$key]); } function session_unregister($key){ unset($_SESSION[$key]); } } if (!function_exists('session_register')) fix_session_register();

至此,织梦网,就可以让DedeCMS在PHP5.4情况中运行了。

织梦仿站 感谢支持织梦之家,你的支持,我们的无限动力!!!
    “DEDECMS教程”欢迎分享!:

    相关标签:PHP5.4(3)PHP高版本(2)dedecms出错(2)

    顶一下
    (0)
    0%
    踩一下
    (0)
    0%

    欢迎您报错,或提出宝贵建议,我们将第一时间处理,为大家营造一个良好网上交流平台,感谢支持织梦之家!

    发表评论
    请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
    评价:
    验证码: 点击我更换图片